Hi,
a suggestion for Kamailio 5.0 is to get rid of the cryptic, case sensitive pseudo-variable names. Instead we replace them with descriptive names like the ones already provided by the TLS module.
The current pseudo variables are a constant nuisance unless you deal with Kamailio every day and know them all by heart. They are an unnecessary barrier for new users learning Kamailio and force you to refer to the documentation more often than necessary.
Ideally there would be a script to replace old variable names in configuration files with the new ones to make the transition less painful.
-Sven