For now, I pushed the new uptime statistic to follow the naming
convention that was in place:
https://www.kamailio.org/docs/modules/devel/modules/xhttp_prom.html#xhttp_p…
We could implement the following naming convention:
# This is the modparam for stats_stats.get_statistics
# kamcmd stats.get_statistics sl:
modparam("xhttp_prom", "stats_stats.get_statistics",
"sl:")
# kamcmd stats.get_statistics 1xx_replies
modparam("xhttp_prom", "stats_stats.get_statistics",
"1xx_replies")
# This is the modparam for stats_pkg.stats
# kamcmd pkg.stats
modparam("xhttp_prom", "stats_pkg.stats", 1)
# This is the modparam for stats_core.uptime
# kamcmd core.uptime
modparam("xhttp_prom", "stats_core.uptime", 1)
With the above naming convention, the existing code will be re-used
and the behaviour of the module will be unchanged.
Support for a list of custom stats from the stats.get_statistics
command can be implemented in the future.
-ovidiu