Discussion to define cmake format options and coding/naming styles. It is better to define most of them now to have coherency in the future. Started from the discussion on #4066.
Comment with what you would like to have, describing when useful why your proposal is a good/better option.
I would propose a longer limit for the line width (`line_width`) - 80 could be too short for comments (some cmake commands also take comment parameter) and string parameters. Nowadays, all displays as well as the terminal apps support way larger number of chars per line.
A second proposal is to have coherence in naming style for cmake-related files. I pushed recently a commit to use `-` (dash) instead of `_` (underscore) in some file names, given that `-` was more common and I suggest to use this style further.
- `dangle_parens = True` : If a statement is wrapped to more than one line, than dangle the closing parenthesis on its own line. This follows closely the whole kamailio codebase, I think. - `keyword_case = 'upper'`: Format keywords consistently as 'lower' or 'upper' case. default was 'unchanged`.
Suggestion to also set `enable_markup = False`.
If true it reflows the comments to the decided `line_width`, disrespecting any new lines that may be intended by the author. Setting to `False` leaves the comments as written without alterning the new lines, and I believe is better for clarity.
This issue is stale because it has been open 6 weeks with no activity. Remove stale label or comment or this will be closed in 2 weeks.
I guess this can be closed now? Or is there still something to be done regarding the cmake styling.