You are welcome to work and propose a patch (pull request), definitely it will be considered and merged if doesn't break other things -- I think this extra option is useful.
As an alternative to the idea of having a parameter before the listen like with the workers, could be specified inline like the alias, eg:
``` listen=proto:addr:port alias addrx:portx mcast xyz ```
Anyhow, whatever you prefer, it's fine.
Eventually, in the future (if nobody wants to do it right now) we can consider adding another structure-like to group the attributes for a socket and make it more clear where they are applied (so the order doesn't matter that much anymore), something like:
``` socket { listen=proto:addr:port alias addrx:portx workers=4 mcast=xyz } ```