Hello,
This is Luis Martin. I am developing a new module for Kamailio. This module
will include some functions which will allow Kamailio to connect to another
servers and retrieve information. I'm thinking on creating a couple of child
from my main function, each child will execute a query to an specific
server. I read this file "doc/modules_init.txt", but I'm having some
troubles and I would appreciate if you could please help me with this.
This is the how the the first draft of the forking code looks like:
http://pastebin.com/MLXDN9p9
I call the "mod_child" function from my function like this:
int myFunction () {
(...)
mod_child(randomNUMBER);
(...)
}
But nothing happens, neither during the compilation process, nor the
execution. Nothing is printed on the logs. Can you please point me out any
suggestion or example?
- How I am supposed to call the "mod_child()" function?
- Which should be the rank_number: PROC_MAIN?
- How I am supposed to cal the "mod_init()" function?
- Again, could you please provide my any example?
Thanks a lot.
Best,
Luis Martin
THIS IS AN AUTOMATED MESSAGE, DO NOT REPLY.
A new Flyspray task has been opened. Details are below.
User who did this - Juha Heinanen (jh)
Attached to Project - sip-router
Summary - domain class AVPs are not stored in transaction
Task Type - Bug Report
Category - tm
Status - Assigned
Assigned To - Andrei Pelinescu-Onciul
Operating System - All
Severity - Medium
Priority - Normal
Reported Version - Development
Due in Version - Undecided
Due Date - Undecided
Details - as discussed earlier, domain class AVPs are not stored in transaction.
More information can be found at the following URL:
http://sip-router.org/tracker/index.php?do=details&task_id=161
You are receiving this message because you have requested it from the Flyspray bugtracking system. If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.
THIS IS AN AUTOMATED MESSAGE, DO NOT REPLY.
A user has added themself to the list of users assigned to this task.
FS#161 - domain class AVPs are not stored in transaction
User who did this - Juha Heinanen (jh)
http://sip-router.org/tracker/index.php?do=details&task_id=161
You are receiving this message because you have requested it from the Flyspray bugtracking system. If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.
Hi SR-DEV people-
I've been lurking in this list for about six months. I'm CTO of a
Luxembourg-based VOIP company. I'll be attending the Kamailio Advanced
Training class in Berlin this October 10. I've been learning and using
Kamailio for months, and still have a lot to learn. I thought I'd introduce
myself and say, "Hello". I hope to meet some of the people on this list in
a few weeks.
Regards,
Bruce Stephenson
CTO Starnumber
energyscholar(a)gmail.com
Hi Loïc
This post is best suited for the developer list. There is a problem here
with the fact that Client_Ro requires some extra API function in the dialog
module which are not part of the stock kamailio dialog module. I could give
you a fix but we are currently finalising an overhaul to sort these small
incompatibilities out. We will be releasing in the next week to 10 days
It also seems like the changes we made to cdp_avp have also not been
included in Carsten's branch. another reason to just hang 5 till we release
Sorry for inconvenience
Cheers
Jason
On Tue, Sep 27, 2011 at 11:22 AM, <loic.trottin(a)orange.com> wrote:
> **
> Hi all,
>
> I try to compile Kamailio with IMS extensions from OpenIMSCore available
> in carstenbock/ims branch in the GIT repository.
> I have some problems with the modules "Client_Ro" and "pcscf" that do not
> compile:
>
> CC (gcc) [M Client_Ro.so] ims_ro.o
> ims_ro.c: In function ‘send_ccr_interim’:
> ims_ro.c:594: error: ‘AVP_EPC_User_Equipment_Info_Type_MAC’ undeclared
> (first use in this function)
> ims_ro.c:594: error: (Each undeclared identifier is reported only once
> ims_ro.c:594: error: for each function it appears in.)
> ims_ro.c: In function ‘send_ccr_stop’:
> ims_ro.c:749: error: ‘AVP_EPC_User_Equipment_Info_Type_MAC’ undeclared
> (first use in this function)
> ims_ro.c: In function ‘Ro_Send_CCR’:
> ims_ro.c:831: error: ‘struct dlg_binds’ has no member named ‘get_dlg’
> ims_ro.c:835: error: ‘struct dlg_binds’ has no member named ‘unref_dlg’
> ims_ro.c:886: error: ‘AVP_EPC_User_Equipment_Info_Type_MAC’ undeclared
> (first use in this function)
> CC (gcc) [M pcscf.so] pcc_avp.o
> pcc_avp.c:1459: error: ‘AVP_IMS_Subscription_Id_Type_E164’ undeclared
> (first use in this function)
> pcc_avp.c:1459: error: (Each undeclared identifier is reported only once
> pcc_avp.c:1459: error: for each function it appears in.)
> pcc_avp.c:1461: error: ‘AVP_IMS_Subscription_Id_Type_SIP_URI’ undeclared
> (first use in this function)
> Does anybody have encountered these problems?
> Is there a stable version tagged of the branch carstenbock/ims available in
> the GIT repository ?
>
> Best regards,
>
> Loïc.
>
>
>
> ********************************************************************************
> IMPORTANT.Les informations contenues dans ce message electronique y compris les fichiers attaches sont strictement confidentielles
> et peuvent etre protegees par la loi.
> Ce message electronique est destine exclusivement au(x) destinataire(s) mentionne(s) ci-dessus.
> Si vous avez recu ce message par erreur ou s il ne vous est pas destine, veuillez immediatement le signaler a l expediteur et effacer ce message
> et tous les fichiers eventuellement attaches.
> Toute lecture, exploitation ou transmission des informations contenues dans ce message est interdite.
> Tout message electronique est susceptible d alteration.
> A ce titre, le Groupe France Telecom decline toute responsabilite notamment s il a ete altere, deforme ou falsifie.
> De meme, il appartient au destinataire de s assurer de l absence de tout virus.
>
> IMPORTANT.This e-mail message and any attachments are strictly confidential and may be protected by law. This message is
> intended only for the named recipient(s) above.
> If you have received this message in error, or are not the named recipient(s), please immediately notify the sender and delete this e-mail message.
> Any unauthorized view, usage or disclosure ofthis message is prohibited.
> Since e-mail messages may not be reliable, France Telecom Group shall not be liable for any message if modified, changed or falsified.
> Additionally the recipient should ensure they are actually virus free.
> ********************************************************************************
>
>
> _______________________________________________
> SIP Express Router (SER) and Kamailio (OpenSER) - sr-users mailing list
> sr-users(a)lists.sip-router.org
> http://lists.sip-router.org/cgi-bin/mailman/listinfo/sr-users
>
>
Module: sip-router
Branch: 3.1
Commit: 97b0120f9e5b5ca96c8ebb746ed46fc6325aca7d
URL: http://git.sip-router.org/cgi-bin/gitweb.cgi/sip-router/?a=commit;h=97b0120…
Author: Henning Westerholt <hw(a)kamailio.org>
Committer: Henning Westerholt <hw(a)kamailio.org>
Date: Tue Sep 27 10:02:50 2011 +0200
pike(k): add parameter unit, reported from dirtytoni at gmx dot de
(cherry picked from commit 98b3adf26f69e5dbbddc36f502b5f2ef1f3a729c)
---
modules_k/pike/README | 16 ++++++++--------
modules_k/pike/doc/pike_admin.xml | 18 +++++++++---------
2 files changed, 17 insertions(+), 17 deletions(-)
diff --git a/modules_k/pike/README b/modules_k/pike/README
index a7c4012..6b5ab24 100644
--- a/modules_k/pike/README
+++ b/modules_k/pike/README
@@ -109,8 +109,8 @@ Chapter 1. Admin Guide
3.1. sampling_time_unit (integer)
- Time period used for sampling (or the sampling accuracy ;-) ). The
- smaller the better, but slower. If you want to detect peeks, use a
+ Time period in seconds used for sampling (or the sampling accuracy).
+ The smaller the better, but slower. If you want to detect peeks, use a
small one. To limit the access (like total number of requests on a long
period of time) to a proxy resource (a gateway for ex), use a bigger
value of this parameter.
@@ -142,12 +142,12 @@ modparam("pike", "reqs_density_per_unit", 30)
3.3. remove_latency (integer)
For how long the IP address will be kept in memory after the last
- request from that IP address. It's a sort of timeout value. Note that
- it is not the duration to keep the IP in state 'blocked'. An IP is
- unblocked next occurence of 'sampling_time_unit' that does not exceed
- 'reqs_density_per_unit'. Keeping an IP in memory results in faster
- reaching of blocked state -- see the notes about the limits of getting
- to state 'blocked'.
+ request from that IP address. It's a sort of timeout value, in seconds.
+ Note that it is not the duration to keep the IP in state 'blocked'. An
+ IP is unblocked next occurence of 'sampling_time_unit' that does not
+ exceed 'reqs_density_per_unit'. Keeping an IP in memory results in
+ faster reaching of blocked state -- see the notes about the limits of
+ getting to state 'blocked'.
Default value is 120.
diff --git a/modules_k/pike/doc/pike_admin.xml b/modules_k/pike/doc/pike_admin.xml
index 3b72316..89d9f27 100644
--- a/modules_k/pike/doc/pike_admin.xml
+++ b/modules_k/pike/doc/pike_admin.xml
@@ -61,9 +61,9 @@
<section>
<title><varname>sampling_time_unit</varname> (integer)</title>
<para>
- Time period used for sampling (or the sampling accuracy ;-) ). The
- smaller the better, but slower. If you want to detect peeks, use a
- small one. To limit the access (like total number of requests on a
+ Time period in seconds used for sampling (or the sampling accuracy).
+ The smaller the better, but slower. If you want to detect peeks, use
+ a small one. To limit the access (like total number of requests on a
long period of time) to a proxy resource (a gateway for ex), use
a bigger value of this parameter.
</para>
@@ -111,12 +111,12 @@ modparam("pike", "reqs_density_per_unit", 30)
<title><varname>remove_latency</varname> (integer)</title>
<para>
For how long the IP address will be kept in memory after the last
- request from that IP address. It's a sort of timeout value. Note that
- it is not the duration to keep the IP in state 'blocked'. An IP is
- unblocked next occurence of 'sampling_time_unit' that does not exceed
- 'reqs_density_per_unit'. Keeping an IP in memory results in faster
- reaching of blocked state -- see the notes about the limits of getting
- to state 'blocked'.
+ request from that IP address. It's a sort of timeout value, in seconds.
+ Note that it is not the duration to keep the IP in state 'blocked'. An
+ IP is unblocked next occurence of 'sampling_time_unit' that does not
+ exceed 'reqs_density_per_unit'. Keeping an IP in memory results in
+ faster reaching of blocked state -- see the notes about the limits of
+ getting to state 'blocked'.
</para>
<para>
<emphasis>
Module: sip-router
Branch: master
Commit: 98b3adf26f69e5dbbddc36f502b5f2ef1f3a729c
URL: http://git.sip-router.org/cgi-bin/gitweb.cgi/sip-router/?a=commit;h=98b3adf…
Author: Henning Westerholt <hw(a)kamailio.org>
Committer: Henning Westerholt <hw(a)kamailio.org>
Date: Tue Sep 27 10:02:50 2011 +0200
pike(k): add parameter unit, reported from dirtytoni at gmx dot de
---
modules_k/pike/README | 16 ++++++++--------
modules_k/pike/doc/pike_admin.xml | 18 +++++++++---------
2 files changed, 17 insertions(+), 17 deletions(-)
diff --git a/modules_k/pike/README b/modules_k/pike/README
index 394cf96..99c0634 100644
--- a/modules_k/pike/README
+++ b/modules_k/pike/README
@@ -107,8 +107,8 @@ Chapter 1. Admin Guide
3.1. sampling_time_unit (integer)
- Time period used for sampling (or the sampling accuracy ;-) ). The
- smaller the better, but slower. If you want to detect peeks, use a
+ Time period in seconds used for sampling (or the sampling accuracy).
+ The smaller the better, but slower. If you want to detect peeks, use a
small one. To limit the access (like total number of requests on a long
period of time) to a proxy resource (a gateway for ex), use a bigger
value of this parameter.
@@ -140,12 +140,12 @@ modparam("pike", "reqs_density_per_unit", 30)
3.3. remove_latency (integer)
For how long the IP address will be kept in memory after the last
- request from that IP address. It's a sort of timeout value. Note that
- it is not the duration to keep the IP in state 'blocked'. An IP is
- unblocked next occurence of 'sampling_time_unit' that does not exceed
- 'reqs_density_per_unit'. Keeping an IP in memory results in faster
- reaching of blocked state -- see the notes about the limits of getting
- to state 'blocked'.
+ request from that IP address. It's a sort of timeout value, in seconds.
+ Note that it is not the duration to keep the IP in state 'blocked'. An
+ IP is unblocked next occurence of 'sampling_time_unit' that does not
+ exceed 'reqs_density_per_unit'. Keeping an IP in memory results in
+ faster reaching of blocked state -- see the notes about the limits of
+ getting to state 'blocked'.
Default value is 120.
diff --git a/modules_k/pike/doc/pike_admin.xml b/modules_k/pike/doc/pike_admin.xml
index 3b72316..89d9f27 100644
--- a/modules_k/pike/doc/pike_admin.xml
+++ b/modules_k/pike/doc/pike_admin.xml
@@ -61,9 +61,9 @@
<section>
<title><varname>sampling_time_unit</varname> (integer)</title>
<para>
- Time period used for sampling (or the sampling accuracy ;-) ). The
- smaller the better, but slower. If you want to detect peeks, use a
- small one. To limit the access (like total number of requests on a
+ Time period in seconds used for sampling (or the sampling accuracy).
+ The smaller the better, but slower. If you want to detect peeks, use
+ a small one. To limit the access (like total number of requests on a
long period of time) to a proxy resource (a gateway for ex), use
a bigger value of this parameter.
</para>
@@ -111,12 +111,12 @@ modparam("pike", "reqs_density_per_unit", 30)
<title><varname>remove_latency</varname> (integer)</title>
<para>
For how long the IP address will be kept in memory after the last
- request from that IP address. It's a sort of timeout value. Note that
- it is not the duration to keep the IP in state 'blocked'. An IP is
- unblocked next occurence of 'sampling_time_unit' that does not exceed
- 'reqs_density_per_unit'. Keeping an IP in memory results in faster
- reaching of blocked state -- see the notes about the limits of getting
- to state 'blocked'.
+ request from that IP address. It's a sort of timeout value, in seconds.
+ Note that it is not the duration to keep the IP in state 'blocked'. An
+ IP is unblocked next occurence of 'sampling_time_unit' that does not
+ exceed 'reqs_density_per_unit'. Keeping an IP in memory results in
+ faster reaching of blocked state -- see the notes about the limits of
+ getting to state 'blocked'.
</para>
<para>
<emphasis>