Daniel-Constantin Mierla writes:
In other words, add_contact_alias() can be pointed directly to set_contact_alias() and no functionality is lost. Ovidiu's suggestion is to deprecate it and remove it in future version.
is there any performance difference when change is made immediately to sip message?
if not, i still don't understand why add_contact_alias was not simply modified instead of creating a new function. why don't you rename set_contact_alias to add_contact_alias and deprecate set_contact_alias, since i bet that add_contact_alias is as older function used in more configs than set_contact_alias?
-- juha