Looking at the patch, it is rather clear that the developer wanted to have @ realm, because there is explicit concatenation. So I think the correct way would be to fix documentation based on code, not the code based on wiki documentation, specially given the age of the code in this case. Eventually a new variable can be added if something else is needed.