Module: sip-router
Branch: andrei/tcp_tls_changes
Commit: 9318b4cbc6e78dd0f28860b0d89e649f9aa17125
URL: http://git.sip-router.org/cgi-bin/gitweb.cgi/sip-router/?a=commit;h=9318b4c…
Author: Andrei Pelinescu-Onciul <andrei(a)iptel.org>
Committer: Andrei Pelinescu-Onciul <andrei(a)iptel.org>
Date: Sun Aug 15 18:10:42 2010 +0200
tls: verbose debugging for SSL_ERROR_WANT_WRITE
Debugging messages for partial write and SSL_ERROR_WANT_WRITE
(enabled only if the tls module is compiled with
-DTLS_WR_DEBUG and -DTLS_RD_DEBUG).
---
modules/tls/tls_server.c | 6 ++++++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/modules/tls/tls_server.c b/modules/tls/tls_server.c
index a910767..5ccf545 100644
--- a/modules/tls/tls_server.c
+++ b/modules/tls/tls_server.c
@@ -787,6 +787,10 @@ redo_wr:
/* this function should be called again => disallow
immediate closing of the connection */
send_flags->f &= ~SND_F_CON_CLOSE;
+ TLS_WR_TRACE("(%p) SSL_ERROR_WANT_WRITE partial write"
+ " (written %p , %d, rest_buf=%p"
+ " rest_len=%d))\n", c, buf, offs,
+ *rest_buf, *rest_len);
}
break; /* or goto end */
case SSL_ERROR_SSL:
@@ -1157,6 +1161,8 @@ ssl_read_skipped:
/* something was written => buffer not big enough to hold
everything => reset buffer & retry (the tcp_write already
happened if we are here) */
+ TLS_RD_TRACE("(%p) SSL_ERROR_WANT_WRITE partial write"
+ " (written %d), retrying\n", c, wr.used);
goto continue_ssl_read;
}
/* else write buffer too small, nothing written */
Hello all,
I would like to propose a split of the k nathelper module in two:
- nathelper module - will keep functionality related only to NAT handling;
- rtpproxy module - a new module that will handle rtpproxy protocol
communication between kamailio and rtpproxy.
The config will require the load of the new rtpproxy module and all
the rtpproxy config params will be moved from nathelper to rtpproxy.
All functions will remain the same inside the routing blocks.
Before proceeding with this task, I would like to know if there are
any objections to this split.
Regards,
Ovidiu Sas
Module: sip-router
Branch: master
Commit: c16a8388b124a3070c14ef4f3e5b8d73ec0f724c
URL: http://git.sip-router.org/cgi-bin/gitweb.cgi/sip-router/?a=commit;h=c16a838…
Author: Andrei Pelinescu-Onciul <andrei(a)iptel.org>
Committer: Andrei Pelinescu-Onciul <andrei(a)iptel.org>
Date: Fri Aug 13 21:44:36 2010 +0200
Merge remote branch 'origin/andrei/cancel_reason'
CANCEL Reason support, according to RFC 3326.
The Reason headers are added both for CANCELs generated due to a
received final reply and hop by hop CANCELs generated because of
a received CANCEL. Both cases can be turned on/off individually.
* origin/andrei/cancel_reason:
tm: no reason modparams if compiled with no cancelr. support
tm: option to compile without reason support
tm: docs: reason header modparams and script function
tm: improved Reason support for E2E CANCELs
tm: fix Reason generation for on-the-fly branch CANCELs
tm: CANCEL reason header on/off switches
tm: Reason header copy for received CANCELs
tm: Reason header generation for local CANCELs
---