[SR-Users] Garbage in to field

Daniel-Constantin Mierla miconda at gmail.com
Tue May 8 08:35:33 CEST 2018


this is somehow by design from early days of the application (2001-2003)
for speed purposes (at that time such optimizations matter for high
capacity) and it got propagated over the time.

More about it can be found in FAQ (I extended right now with a bit more
details about this specific case):



On 08.05.18 01:11, Kjeld Flarup wrote:
> I'm having problems with my To field.
> I'm doing an async_route, and afterwards sends the call with auth to a
> SIP server.
> My problem is that in the first invite I see the expected To field
> sip:004520202020 at isp.com
> But when the Auto is send the To field is changed to the, To field for
> the PBX
> sip:1234 at pbx.local
> I tried to fix this with uac_replace_to("$ru"), but that ends up in
> this To field:
> sip:004520202020 at isp.comsip:004520202020 at isp.com
> It seems like uac_replace_to sometimes appends rather that replaces.
> If I run it twice, then it for sure appends. Is this expected behaviour.

Daniel-Constantin Mierla
www.twitter.com/miconda -- www.linkedin.com/in/miconda
Kamailio World Conference - May 14-16, 2018 - www.kamailioworld.com

More information about the sr-users mailing list