[SR-Users] Garbage in to field

Kjeld Flarup kjeld.flarup at liberalismen.dk
Tue May 8 01:11:00 CEST 2018

I'm having problems with my To field.

I'm doing an async_route, and afterwards sends the call with auth to a 
SIP server.

My problem is that in the first invite I see the expected To field
sip:004520202020 at isp.com

But when the Auto is send the To field is changed to the, To field for 
the PBX
sip:1234 at pbx.local

I tried to fix this with uac_replace_to("$ru"), but that ends up in this 
To field:
sip:004520202020 at isp.comsip:004520202020 at isp.com

It seems like uac_replace_to sometimes appends rather that replaces.
If I run it twice, then it for sure appends. Is this expected behaviour.

-------------------- Med Liberalistiske Hilsner ----------------------
    Civilingeniør, Kjeld Flarup - Mit sind er mere åbent end min tegnebog
    Sofienlundvej 6B, 7560 Hjerm, Tlf: 40 29 41 49
    Den ikke akademiske hjemmeside for liberalismen - www.liberalismen.dk

More information about the sr-users mailing list