[SR-Users] [pua] Question to DB Mode 0

Maciej Marczyński bamaciej999 at gmail.com
Sat Oct 3 12:06:41 CEST 2015

Hi Guys,
I have a question regarding pua module parameter 'db mode'.
I run Kamailio (4.3.2) with sqlite and I tried to set the parameter to 0
but even then I received:

> ERROR: db_sqlite [dbase.c:489]: db_sqlite_commit(): sqlite commit failed: NOT NULL constraint failed: pua.call_id
> ERROR: db_sqlite [dbase.c:138]: db_sqlite_cleanup_query(): finalize failed: NOT NULL constraint failed: pua.call_id
> ERROR: pua [pua.c:1179]: db_update(): while inserting in db table pua
> As far as I checked the documentation, it says that '0' means:

> high speed memory based storage

Does it still writes to DB anyway (on timer or whatever?) or just keep it
in memory? Is there any way to disable writing to DB?

The second thing is the reason of the ERRORs above. Why does pua think that
my call_id is null?

If you need any more information please let me know.

Best regards and have a good weekend,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-users/attachments/20151003/88b42ca0/attachment.html>

More information about the sr-users mailing list