[SR-Users] rtpproxy_offer and fix_nated_sdp in one route

Sebastian Damm damm at sipgate.de
Wed Sep 24 15:16:35 CEST 2014


I switched from rtpproxy module to the rtpproxy-ng module lately, and
noticed a strange behavior. In my branch route to the device, I have two


The first command appends a line with "direction:active" to the SDP. The
second one puts the RTP proxy in the stream. This worked all well with the
old rtpproxy module. But with the new rtpproxy-ng module, I get an empty
line after the SDP body, just before the "direction:active" line in the
SDP, which makes the packet invalid.

I tried changing the order of both statements, but without any difference.
What I saw is, that the old module just sent some basic parameters to the
rtpproxy and got only IP and port back. The new module sends the complete
SDP to the rtpengine and gets back the "fixed" SDP.

Has anyone ever seen this? Is there a way to fix it?

Best Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-users/attachments/20140924/3f07153c/attachment.html>

More information about the sr-users mailing list