[SR-Users] Phones losing registration.

arun Jayaprakash jayaprakasharun at yahoo.com
Tue Oct 1 20:26:23 CEST 2013

I think I found the error, but I need  to double check. I was not able to get any log output  in kamailio.log and I noticed that the log file was very large ( I had not set up log rotate ). I cleaned this file and now I am able to view my log outputs. Will this issue in my log file affect the performance of the system?


 From: Daniel-Constantin Mierla <miconda at gmail.com>
To: arun Jayaprakash <jayaprakasharun at yahoo.com>; Kamailio (SER) - Users Mailing List <sr-users at lists.sip-router.org> 
Sent: Tuesday, October 1, 2013 11:14 AM
Subject: Re: [SR-Users] Phones losing registration.


first you should clarify what you mean by "phones are losing
    registration". Do they indicate are not registered?

I suggest few things:
- add a xlog message at beginning of the request_route block to log
    method, callid, from, to, r-uri and source ip
- when the phones are not registered check the logs to see if there
    was a message related to register requests from that phone

You should also log the sip traffic, you can use ngrep to save it in
    a file, so you can look in more details if needed.

Some phones have also good troubleshooting options, at least snom
    phone give a log and the sip trace via web interface. If you have
    one, use it to see what it is reporting.

I guess you checked the syslog file for error messages. If it is
    something that makes kamailio not working properly, you should see
    it there.


On 10/1/13 5:41 PM, arun Jayaprakash wrote:

>I am running into a problem with my set up. I have Kamailio 4.0 set up with an Asterisk server (ARA). Initially I had three machines; one for Kamailio, one for Asterisk and one for my db. The set up worked fine for about a week after which I saw that my phones were losing registration for prolonged periods and then would re-register after a few hours. So what I did was to move Asterisk and Kamailio on the same server and only had my DB on a separate machine. All worked well for about a week and now I am facing the same issue.  At any given time all my services ( kamailio, Asterisk, RTPproxy) are all running. My question is where and how do I start to trouble shoot this issue? I have not really done any debugging in the past so I would appreciate any pointers as to where to start? Thank you for your help.
SIP Express Router (SER) and Kamailio (OpenSER) - sr-users mailing list sr-users at lists.sip-router.org http://lists.sip-router.org/cgi-bin/mailman/listinfo/sr-users 

Daniel-Constantin Mierla - http://www.asipto.com http://twitter.com/#!/miconda - http://www.linkedin.com/in/miconda Kamailio Advanced Trainings - Berlin, Nov 25-28; Miami, Nov 18-20, 2013 - more details about Kamailio trainings at http://www.asipto.com - 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-users/attachments/20131001/22ffd567/attachment-0001.html>

More information about the sr-users mailing list