[SR-Users] Why my kamailio only support 1 TLS connection

Derrick Ding dding at aastra.com
Tue Nov 19 22:00:58 CET 2013

Also tried:
modparam("tls", "low_memory_threshold1", 0)
modparam("tls", "low_memory_threshold2", 0)
same error.

And by default, compression is disabled. So strange error.

-----Original Message-----
From: sr-users-bounces at lists.sip-router.org [mailto:sr-users-bounces at lists.sip-router.org] On Behalf Of Derrick Ding
Sent: Tuesday, November 19, 2013 3:19 PM
To: 'Kamailio (SER) - Users Mailing List'
Subject: [SR-Users] Why my kamailio only support 1 TLS connection

Hi All,

Need some help of setup TLS on Kamailio.
Currently my Kamailio TLS works, but only support one client register successfully. If there's another client want to setup TLS connection, it shows:
tls [tls_server.c:392]: SSL error:error:07064041:memory bufferoutines:BUF_MEM_grow:malloc failure.

I have modified /etc/default/Kamailio
But the error is still there.

The client A and B share same private key and Trusted Certificate. I don't know if this is correct or this is the cause that second TLS failure.

Can anyone help me? I can provide log or config if necessary.


SIP Express Router (SER) and Kamailio (OpenSER) - sr-users mailing list
sr-users at lists.sip-router.org

More information about the sr-users mailing list