[SR-Users] Undefined Symbol Error in TLS.so

Daniel-Constantin Mierla miconda at gmail.com
Sat Nov 2 19:36:58 CET 2013


what operating system do you use? How did you installed Kamailio?

log_color is defined in core, used for debug messages. I included the 
respective header in all tls files, you can try to see if you still get 
the issues by re-installing the latest git branch 4.0 (see wiki on 
kamailio.org for a tutorial, if you are not familiar with).


On 11/2/13 2:54 PM, Mark Zeman wrote:
> Hi,
> I'm trying to set up a Kamailio server for a project at university, and
> have some trouble with it.
> Since Kamailio isn't starting, I use the 'kamailio -c -f kamailio.cfg'
> command to figure out what's wrong.
> This tells me that it cannot load the tls.so file, because of 'undefined
> symbol: log_color.
> I've tried to recompile the TLS module, but that hasn't helped.
> Does anyone know how to fix this?
> Cheers,
> Mark
> _______________________________________________
> SIP Express Router (SER) and Kamailio (OpenSER) - sr-users mailing list
> sr-users at lists.sip-router.org
> http://lists.sip-router.org/cgi-bin/mailman/listinfo/sr-users

Daniel-Constantin Mierla - http://www.asipto.com
http://twitter.com/#!/miconda - http://www.linkedin.com/in/miconda
Kamailio Advanced Trainings - Berlin, Nov 25-28
   - more details about Kamailio trainings at http://www.asipto.com -

More information about the sr-users mailing list