[SR-Users] Problem with include_file quotes

Pirjo Ahvenainen pirjo.ahvenainen at gmail.com
Fri Nov 16 10:11:10 CET 2012

Hi again,

Looks like I solved my own problem quickly: I tried adding a space
after each include_file "file.cfg" statement and now config file check
passes ok! Before I only had crlf after the quotes.

Just for curiosity, is this intentional and if so, what is the purpose
of whitespace after the quotes?


2012/11/16 Pirjo Ahvenainen <pirjo.ahvenainen at gmail.com>:
> Hi All,
> I've been away from Kamailio for a few months, but recently I started
> working with it again. I could use a hand in a small problem:
> I'm using include_file statement to give some structure to my config
> file, but when checking the config I keep getting error message:
> 0(4290) : <core> [cfg.lex:1554]: included file name must be between
> quotes: "defined_modules.cfg"
> I'm using Kamailio 3.3.2 (version: kamailio 3.3.2 (x86_64/linux)
> 78d4b1) on Ubuntu.
> And here's the beginnign of the config file:
> #
> include_file "defined_modules.cfg"
> include_file "defined_values.cfg"
> include_file "global_parameters.cfg"
> Those look like quotes to me, but could the problem be something like
> encoding of the config file itself, something in the included files,
> or is there something else I can check? I don't have extra whitespaces
> etc, perhaps a typo I just don't see?
> Cheers,
> Pirjo


Pirjo Ahvenainen
+35844 559 7729

More information about the sr-users mailing list