[Users] tm:t_write_unix: write_to_unixsock failed

Bogdan-Andrei Iancu bogdan at voice-system.ro
Fri Jan 26 10:41:15 CET 2007

Hi Peter,

it is good to know that a solution was found. Now we have an answer for 
people reporting similar problems.

Thanks and regards,

Peter Lemenkov wrote:

> 2007/1/16, Bogdan-Andrei Iancu <bogdan at voice-system.ro>:
>> Hi Peter,
>> do you get this error all the time?
> Yes. Everytime I tried....
>> have you tried on a different
>> machine?
> Yes. I tried also at Fedora Core 6 box and everything works fine.
>> I guess the error is not related to SEMS specifically, as it is
>> generated by "writev" in openser.
>> any additional info will be helpful.
> I've found the solution.
> Using strace Isaw that OpenSER tried to allocate too many (doesn't
> matte how many - this definitely an erroneous value) memory then tried
> to write to unix-socket. Googling for similar bugs I've found that's a
> known one with GCC 3.4.x and Glibc 2.3.x (not gentoo-specific as I
> understand).
> I didn't want to find out a solution for an ancient gcc and ancient
> glibc, so I just upgraded them - the bug was gone...

More information about the sr-users mailing list