[Serusers] Problem starting SER with MYSQL

Champike Munasinghe champike at hotmail.com
Tue Jul 25 10:48:42 CEST 2006

Hi, Thanks for the message, I found libmysqlclient.so.10 in /usr/lib/mysql, tried creating a symbolic link to it in /usr/local/lib/ser/modules, that didnt work. Then I copied libmysqlclient.so.10 to /usr/local/lib/ser/modules as libmysqlclient.so.12, that didnt work either, I still get exactly the same error saying "ser: ERROR: load_module: could not open module </usr/local/lib/ser/modules/mysql.so>: libmysqlclient.so.12: cannot open shared object file: No such file or directory" I am sure the file does exist, still SER complains No such file or directory.... Isnt this very very strange? Anyother ideas?Thanks again! Cheers ^C     _____________________________________________________________Hi,libmysqlclient.so.x exist under /usr/local/lib/mysql/ in FreeBSD. Ihave SER running on my FreeBSD 5.4 box now and I had this problembefore as well. What I did is just created a symbolic llink tolibmysqlcllient.so.10, named libmysqlclient.so.12 as in# cd /usr/local/lib/mysql# ln -s libmysqlclient.so.10 libmysqlclient.so.12Though some ppl might discourage such a practice, it works well for me.   Andrey.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-users/attachments/20060725/a3f7b867/attachment.htm>

More information about the sr-users mailing list