[Serusers] Problem starting SER with MYSQL

Champike Munasinghe champike at hotmail.com
Mon Jul 24 16:36:12 CEST 2006

I've downloaded and installed SER 0.9.6 on my Fedora Core system running MySQL 4.1.11-0.
When I start SER without modifying the /usr/local/etc/ser/ser.cfg file, it starts normally. However, when I make the modifications to use MySQL for the database, following Dan Austin's HOWTO, I get the following error:
Jul 24 15:09:45 sipgw ser: ERROR: load_module: could not open module </usr/local/lib/ser/modules/mysql.so>: libmysqlclient.so.12: cannot open shared object file: No such file or directoryJul 24 15:09:45 sipgw ser: parse error (28,13-14): failed to load module
mysql.so does exist in the /usr/local/lib/ser/modules directory, but libmysqlclient.so.12 doesnt. I found libmysqlclient.so.14 in /usr/lib/mysql directory and tried creating a symbolic link called libmysqlclient.so.12 to that file, this didnt work. Also, I tried copying the so.14 file into /usr/local/lib/ser/modules as libmysqlclient.so.12, still got the same error.
I tried searching the lists, but couldnt find any info that mentioned anything about this issue. Am I doing something really stupid here? 
Thanks for your help
Cheers!! -CM
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-users/attachments/20060724/963968e7/attachment.htm>

More information about the sr-users mailing list