[Serusers] SER + SEMS

Kapil Dhawan sersavvy at hotmail.com
Tue Feb 24 09:57:48 CET 2004

one more thing
i am using this also

LD_ASSUME_KERNEL=2.4.1 as i am linux 9.0 so read it in sems REDME that this 
variable shud be exported

still same

>From: "Kapil Dhawan" <sersavvy at hotmail.com>
>To: serusers at lists.iptel.org
>Subject: [Serusers] SER + SEMS
>Date: Tue, 24 Feb 2004 07:29:16 +0000
>Hi All...
>i am running SER perfectly....Now i am facing problem with running SEMS....
>i have tried SER 0.8.12(current sems cvs update ) and 0.8.11(sems 0.11) i 
>am unable to do anything....
>whats happening is....
>my SER is already installed.....and working...now i am compiling it with vm 
>module and making Multi Domain off (in 0.8.11) and its off in 0.8.12 as it 
>depends upon domain module there....so no problem with multidomain 
>support...so it works fine...following is the code of ser.cfg
>                if(method=="ACK" || method=="INVITE" || method=="BYE"){
>                  if (!t_newtran()) {
>                    log("could not create new transaction\n");
>                    sl_send_reply("500","could not create new 
>                    break;
>                  };
>                if(!vm("/tmp/am_fifo", "voicemail")){
>                lookup("aliases");
>                if (!uri==myself) {
>                        append_hf("P-hint: outbound alias\r\n");
>                        route(1);
>                        break;
>                };
>                # native SIP destinations are handled using our USRLOC DB
>                if (!lookup("location")) {
>                        sl_send_reply("404", "Not Found");
>                        break;
>                };
>                };
>                };
>Next....is i am compiling current version of sems...from cvs with following 
>CVSROOT=:pserver:anonymous at cvs.berlios.de:/cvsroot/sems
>export CVSROOT
>cvs co answer_machine
>now it also gets compiled with one or two erros of audio file paths 
>etc...which i corrected in /etc/sems/sems.conf and enaled voicemail module 
>in it..
>Now when i run it sems -D 3 -E
>it shows me sems started successsfully.....but when i try and give a call 
>so that it shud be transfered to voicemail...in sems log i see ## Wrong 
>FIFO Interface version ##
>due to which ...my wav file which is getting stored in /tmp folder is 
>having 44 bytes size always...i know there is version conflict...but i am 
>unable to get proper matching versions of both.............
>kidly help me out...if u need i can attach any more info too...
>Contact brides & grooms FREE! http://www.shaadi.com/ptnr.php?ptnr=hmltag 
>Only on www.shaadi.com. Register now!
>Serusers mailing list
>serusers at lists.iptel.org

Oscar fever is on! It's Hollywood's biggest party. 
http://server1.msn.co.in/sp04/oscars/index.asp Get all the dope here.

More information about the sr-users mailing list