[Serusers] SER/SERWeb Howto...

MANSOOR Usama FTRD/DMR/LON usama.mansoor at rd.francetelecom.com
Thu Dec 12 11:38:42 CET 2002

OK, I've tried running the script as root (and it prompts me for the password) but the permissions still don't get set. So I then log in manually to the mysql database and set the permissions using 'GRANT' to be the same as mentioned in the faq. Unfortunately I still get the following error message:

Dec 12 10:20:25 localhost /usr/sbin/ser[14700]: connect_db(): Access denied for user: 'user at localhost.localdomain' (Using password: YES) 
Dec 12 10:20:26 localhost /usr/sbin/ser[14700]: db_init(): Error while trying to connect database 
Dec 12 10:20:26 localhost /usr/sbin/ser[14700]: init_modules(): Error while initializing module jabber

I'm not sure what else to try. Any suggestions would be much appreciated.

- Usama

-----Original Message-----
From: Dan Austin [mailto:Dan_Austin at Phoenix.com]
Sent: Friday, December 06, 2002 5:41 PM
To: serusers at lists.iptel.org
Subject: RE: RE: [Serusers] SER/SERWeb Howto...

Are you running the script as root?  Before upgrading MySQL I did use the grant command,
and managed to get the correct permissions installed.  I ran into other problems with the
client libraries, so I did a complete upgrade.

After upgrading the ser_mysql.sh script did everyting it should have and I did not need to
make any changes.

I'm also fairly new to MySQL, but from your error message, it looks like you are running
the script from an account that does not have permissions inside the database.

As root if you run mysql, does it prompt for a password?  From your select statement, I
would not expect it to.  If it allows you to logon to the database, you can try to assign the
default permissions manually.



More information about the sr-users mailing list