[SR-Dev] library naming
andrei at iptel.org
Tue Dec 16 14:27:40 CET 2008
On Dec 16, 2008 at 15:02, Daniel-Constantin Mierla <miconda at gmail.com> wrote:
> I couldn't get the message with a final decision regarding the library
> naming scheme.
> Andrei used libsr_xyz at some point, I also like this one. Henning
> committed directly lib/trie in his branch.
It looks like most people prefer libsrxyz (without '_'). At least
everybody agreed with libsrdb1 and libsrdb2.
> I will look soon to make the library out of mi, thinking of: libsr_kmi
> or libsr_mi, depending or not whether we want to mark the origin.
> So, two things to decide:
> - do we stick to libsr_ as prefix to all new libraries included in srouter?
> - do we want to mark the origin of the library? Short term, might be
> good as pattern to know what is required for k version of the module.
IMHO we should mark the origin if there are 2 different versions or if
the lib is transitional (will be obsoleted).
If there is only one version which we will keep (e.g. trie) we don't
As far as mi is concerned, I hope is one of the things that will be
obsoleted in future versions. IMHO is too closely modeled on xmlrpc,
and is far too complex compared with ser rpcs and more difficult to
write. It's true it supports structs inside structs, but I don't think
anybody needs nested structs in a management or rpc interface.
P.S.: the vim git:file plugin is great, e.g.:
More information about the sr-dev