[SR-Dev] library naming

Daniel-Constantin Mierla miconda at gmail.com
Tue Dec 16 14:02:56 CET 2008


I couldn't get the message with a final decision regarding the library 
naming scheme.
Andrei used libsr_xyz at some point, I also like this one. Henning 
committed directly lib/trie in his branch.

I will look soon to make the library out of mi, thinking of: libsr_kmi 
or libsr_mi, depending or not whether we want to mark the origin.

So, two things to decide:
- do we stick to libsr_ as prefix to all new libraries included in srouter?
- do we want to mark the origin of the library? Short term, might be 
good as pattern to know what is required for k version of the module. 
This can be fixed with good documentation. Long term the name might look 


Daniel-Constantin Mierla

More information about the sr-dev mailing list