[SR-Users] No Media in SIP Incoming calls

YASIN CANER caner_yaso at hotmail.com
Thu Jan 10 10:11:40 CET 2019


Kamailio support 2 backend for rtp. RTP Engine and RTP proxy. it depends your configuration. I read from your post that
 "I am not sure if this is an RTP engine issue and how to resolve this." . I thought it is rtpengine.

Indeed , they are different services and has different configuration that do same thing that relays rtp packets.  you can find examples from documentation.

I didnt get internal interface what is mean? but if rtpproxy/engine relays to Asterisk on -lo interface , you should listen your -lo interface by Wireshark.

Good luck.


From: sr-users <sr-users-bounces at lists.kamailio.org> on behalf of Serge S.Yuriev <me at nevian.org>
Sent: Thursday, January 10, 2019 11:30 AM
To: Kamailio (SER) - Users Mailing List
Subject: Re: [SR-Users] No Media in SIP Incoming calls


- I see you mentioned rtpengine but config shows rtpproxy - which one you use? Maybe you mixed things?
- Have you tried to capture internal interface of kamailio machine? Is RTP there?

Wbr, Serge via mobile

09.01.2019, 10:37, "Prashant Gupta" <prashant at farmguide.in>:
I have the following architecture - SIP provider <-> Kamailio <-> Asterisk servers
Currently I have everything setup and incoming calls from Sip are routed to my asterisk server. The issue is however that when I answer the call, there is no media in the call. I have tried connecting with a normal local extension(not SIP,eg 1001) and there is a normal flow of media.
When i try to sniff my connection via Wireshark on the asterisk server, there is an outflow of RTP packets but the same RTP traffic does not appear on the Wireshark of my Kamailio server connection.
I am not sure if this is an RTP engine issue and how to resolve this.
I have -
modparam("rtpproxy", "rtpproxy_sock", "udp:<>")
this in my kamailio cfg but I don;t know which port to use here.
Any suggestions?

Kamailio (SER) - Users Mailing List
sr-users at lists.kamailio.org<mailto:sr-users at lists.kamailio.org>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.kamailio.org/pipermail/sr-users/attachments/20190110/671b470c/attachment.html>

More information about the sr-users mailing list