[SR-Users] Kamailio ims with TCP

Amar Tinawi amar.tinawi at gmail.com
Sun Feb 25 11:38:50 CET 2018

TCP alone errors were strange : on the proxy node i couldn't register and
got the following errors :
Feb 25 12:15:28 server1 [Proxy-CSCF][31641]: ERROR: tm [ut.h:303]:
uri2dst2(): no corresponding socket for "NET.SYRIATEL" af 2
Feb 25 12:15:28 server1 [Proxy-CSCF][31641]: ERROR: tm [t_fwd.c:469]:
prepare_new_uac(): can't fwd to af 2, proto 1  (no corresponding listening
Feb 25 12:15:28 server1 [Proxy-CSCF][31641]: ERROR: tm [t_fwd.c:1735]:
t_forward_nonack(): failure to add branches
Feb 25 12:15:28 server1 [Proxy-CSCF][31641]: ERROR: siptrace
[siptrace.c:1930]: trace_send_hep2_duplicate(): can't forward to af 2,
proto 1 no corresponding listening socket
Feb 25 12:15:28 server1 [Proxy-CSCF][31641]: ERROR: sl [sl_funcs.c:362]:
sl_reply_error(): stateless error reply used: I'm terribly sorry, server
error occurred (7/SL)

These errors appearing when using two TCP and UDP, i could be able to
register and make calls but still get errors
Feb 25 11:37:15 server1 [Proxy-CSCF][28999]: ERROR: ims_usrloc_pcscf
[udomain.c:409]: update_pcontact(): Error updating record in DB
Feb 25 11:37:15 server1 [Proxy-CSCF][28999]: ERROR: ims_registrar_pcscf
[notify.c:218]: process_contact(): failed to update pcscf contact
Feb 25 11:37:15 server1 [Proxy-CSCF][28999]: ERROR: tm [tm.c:1242]:
w_t_reply(): cannot send a t_reply to a message for which no T-state has
been established

In addition i cleaned all UDP SRV related records from DNS zone and tried
to forced all instances in the TCP mode configuration

**Also, in the TCP mode all the  ip addresses that the registrations comes
from are not the real ip's of the users, and also this is very strange
i got some random  IP's

On Fri, Feb 23, 2018 at 10:41 AM, Daniel-Constantin Mierla <
miconda at gmail.com> wrote:

> Hello,
> have you look at syslog messages? Are there any errors? Between Kamailio
> instances, tcp for sip should work. Check also configs to be sure UDP is
> not enforced there.
> Cheers,
> Daniel
> On 22.02.18 12:40, Amar Tinawi wrote:
> Hello list
> For some reason i couldn't register on kamailio ims when i use only TCP
> protocols between nodes, the error was solved when i enabled UDP between
> is it mandatory for those two nodes to talk over UDP only ? or i'm missing
> something ?
> and in general for sip protocol which is better ? UDP or TCP ?
> Regards,
> _______________________________________________
> Kamailio (SER) - Users Mailing Listsr-users at lists.kamailio.orghttps://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users
> --
> Daniel-Constantin Mierlawww.twitter.com/miconda -- www.linkedin.com/in/miconda
> Kamailio Advanced Training - March 5-7, 2018, Berlin - www.asipto.com
> Kamailio World Conference - May 14-16, 2018 - www.kamailioworld.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.kamailio.org/pipermail/sr-users/attachments/20180225/f43b1a07/attachment.html>

More information about the sr-users mailing list