[SR-Users] Blind Transfer WS Error

Matteo Campana matteolists at gmail.com
Wed Feb 7 14:08:59 CET 2018

Dear Kamailians,

does anyone have any idea on the issue below?

Alessio told me that is always reproducible, and he can also provide
captures and more logs.

Thanks in advance!


*From: *sr-users <sr-users-bounces at lists.kamailio.org> on behalf of Alessio
Miranda <smirolandia at gmail.com>
*Reply-To: *"Kamailio (SER) - Users Mailing List" <
sr-users at lists.kamailio.org>
*Date: *Tuesday, 16 January 2018 at 14:18
*To: *"sr-users at lists.kamailio.org" <sr-users at lists.kamailio.org>
*Subject: *[SR-Users] Blind Transfer WS Error


I have a problem with the blind transfer via WebSocket,

debugging from the browser we see that in some cases when the REFER is

done and the sip message "202 Accepted" arrives,

the message "180 Ringing" arrives first and then the "100 Trying"

and the transfer goes in error with "500 JsSIP Internal Error"

I have an architecture with Kamailio in frontend and asterisk in backend

on the same network, the sip dialogue between FE and BE is in SIP / UDP.

The WebRTC client connects to WebSocket at Kamailio's public address.

We have verified that the sip messages exchanged between kamailio and

asterisk are always correct.

Kamailio Ver. 4.4.4

Asterisk Ver. 13.18.3

PJSIP Ver. 2.6

JSSIP Ver. 3.2.2

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.kamailio.org/pipermail/sr-users/attachments/20180207/7a708127/attachment.html>

More information about the sr-users mailing list