[SR-Users] rtpproxy - no media connection

Steve smh2017 at zoho.com
Mon Feb 5 02:25:58 CET 2018

Dear sr-users, 

I am trying to set up a simple Kamailio server with rtpproxy on the same
host computer, behind a NAT router. “Run your own Skype-like service” is
my set-up guide, but I’m using Kamailio version 5.1 so I modified the
config files that came with the download. My problem is that SIP clients
can register over the internet via TLS encryption with the server and
establish a call session connection, but the ZRTP media connection is
not being made. Once the call session connection is made, both clients
send out UDP packets to each other, but neither receives them—the media
traffic is one way and being dropped somewhere. 

I’ve tried different rtpproxy start settings. If I start the rtpproxy
service with “sudo /etc/init.d/rtpproxy start” then it uses the default
“unix:/var/run/rtpproxy/rtpproxy.sock”. I’ve also tried starting with
“sudo rtpproxy –l /my_public_ip/ –s udp:localhost:7722” which then asks
for either –F (superuser) or –u (user). I’ve tried it both with options
“–F” and “-u kamailio kamailio”. All the variations tried so far have
the same result as noted above. 

The server behind the router is in a DMZ zone that bypasses the router

Is there anything in the user-list archives that addresses this issue?
Or some likely place to start troubleshooting the problem?

Any suggestions would be greatly appreciated. Thanks in advance.


This email has been checked for viruses by Avast antivirus software.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.kamailio.org/pipermail/sr-users/attachments/20180204/1f8f5d75/attachment.html>

More information about the sr-users mailing list