[SR-Users] Struggling with RTPProxy and RTPEngine

Wilkins, Steve swwilkins at mitre.org
Wed Aug 22 14:49:54 CEST 2018

Here is my start up =>
rtpengine --interface\! --listen-ng --dtls-passive -f -m 10000 -M 20000  -E -L 7 --log-facility=local1

My offer and answer =>
rtpengine_offer("trust-address replace-session-connection replace-origin");

From: sr-users <sr-users-bounces at lists.kamailio.org> On Behalf Of Wilkins, Steve
Sent: Wednesday, August 22, 2018 8:43 AM
To: Kamailio (SER) - Users Mailing List <sr-users at lists.kamailio.org>
Subject: [SR-Users] Struggling with RTPProxy and RTPEngine

Hello all,

I can't seem to get either RTPProxy or RTPEngine to work correctly.  I have decided to concentrate on RTPEngine because I have read that it works the best. I am using Asterisk with Kamailio in front.  When I make calls, I see RTPEngine being hit but I continually get the error "Call-ID not found", calls work but media traffic doesn't go through RTPEngine.  I have tried many combination of the flags but I seem to always get the same error.    When I look at the tcpdump log, I see that the media offer is not on the RTPEngine port. Is there a common mis-configuration error that can cause this?

I know I can send all my logs and configurations but I really want to try and resolve this as a learning experience.

Thanks all,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.kamailio.org/pipermail/sr-users/attachments/20180822/d0bc7cc8/attachment.html>

More information about the sr-users mailing list