[SR-Users] rtpengine sending rtp to wrong endpoint after reinvite

Grant Bagdasarian gb at cm.nl
Tue Mar 7 13:10:29 CET 2017


One of our customers is using a SEMS box to place two outbound calls using our sip trunk.
Once the first call is connected a second call is placed and when the second call answers their server sends a re-invite to switch audio ports so the rtp traffic doesn't flow through their server anymore but is routed inside our platform.
Basically, they just switch SDP's of both calls.
It seems like a random issue, and is not really reproducible, except for placing multiple calls and sometimes both parties can hear each other, other times they can't, because rtpengine fails (I think) to update the endpoint and keeps sending rtp back to their server for one of the call legs.

We tried to reproduce the case using a freeswitch box and it worked every time. After the reinvite, the rtp remained within our platform.
The signaling in both cases still goes through the freeswitch or sems for call control.

Does anyone have experience with this case? Or seen the issue before where rtpengine keeps sending rtp to the original endpoint?


Grant Bagdasarian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-users/attachments/20170307/947c7eb8/attachment.html>

More information about the sr-users mailing list