[SR-Users] DNS SRV when no NAPTR

Daniel-Constantin Mierla miconda at gmail.com
Wed Sep 18 12:17:06 CEST 2013

On 9/18/13 12:04 PM, Øyvind Kolbu wrote:
> On 18.09.2013 11:32, Olle E. Johansson wrote:
>> 18 sep 2013 kl. 10:55 skrev Daniel-Constantin Mierla <miconda at gmail.com
>> <mailto:miconda at gmail.com>>:
>>> Hello,
>>> to set the preference order for queries, see:
>>> http://www.kamailio.org/wiki/cookbooks/devel/core#dns_sctp_pref_dns_tcp_pref_dns_tls_pref_dns_udp_pref 
>>> By default, the highest is to follow on UDP.
>> But that seems to be for NAPTR and the question was about having no 
>> Or am I just confused?
> Correct, no NAPTR. Only SRV, but until yesterday, no _sip._udp and then
> it immediately tried an A lookup instead of attempting _sip._tcp.
> I have also tried to set those prefs, but it did not help.
I got confused by the tcp dump and missed first remark, I thought udp 
srv query returned two hosts for A lookup, first failing and second not 
tried. I will look again over it.


Daniel-Constantin Mierla - http://www.asipto.com
http://twitter.com/#!/miconda - http://www.linkedin.com/in/miconda
Kamailio Advanced Trainings - Berlin, Oct 21-24; Miami, Nov 11-13, 2013
   - more details about Kamailio trainings at http://www.asipto.com -

More information about the sr-users mailing list