[SR-Users] Problem with my kamailio installation

Ramazan Yilmaz ramazan.cs at gmail.com
Thu Nov 1 15:23:31 CET 2012

In my kamailio configuration, I already have "#!define WITH_TLS". And some
more about my configuration:


#!ifdef WITH_TLS

#!ifdef WITH_TLS
loadmodule "tls.so"

#!ifdef WITH_TLS
# ----- tls params -----
modparam("tls", "config", "/usr/local/kamailio-3.3/etc/kamailio/tls.cfg")

And my tls.cfg is,

method = SSLv23
verify_certificate = no
require_certificate = no
private_key = /usr/local/kamailio-3.3/etc/kamailio/kamailio.key
certificate = /usr/local/kamailio-3.3/etc/kamailio/kamailio.pem

verify_certificate = yes
require_certificate = yes

I have just installed kamailio 3.2.4 on some other server to see whether
the problem is with my configuration/my system or with kamailio release. I
again installed Ubuntu, and I installed the requested packages via apt-get,
as I had done on problematic system. I used exactly the same configuration
file, except changing the domain/ip values. And it worked. Then I used the
same configuration file on some other versions of Ubuntu server, and it
worked again. So, it really seems as a bug in kamailio.

It seems the worker children cannot be forked for some reason at startup,
so I enabled WITH_DEBUG directive and restarted the kamailio. The output is
attached to this mail. I hope it helps.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-users/attachments/20121101/63321db8/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: log.rar
Type: application/rar
Size: 10580 bytes
Desc: not available
URL: <http://lists.sip-router.org/pipermail/sr-users/attachments/20121101/63321db8/attachment.rar>

More information about the sr-users mailing list