[SR-Users] perl module compilation on centos

Yuri Krichevsky yuri.k at ipt.co.il
Thu Sep 22 17:51:23 CEST 2011


Just delete "modules_k/perl/openserxs.c" before compilation.

With Best Regards,
Yuri Krichevsky

From: Daniel-Constantin Mierla <miconda at gmail.com<mailto:miconda at gmail.com>>
Reply-To: "miconda at gmail.com<mailto:miconda at gmail.com>" <miconda at gmail.com<mailto:miconda at gmail.com>>, "SIP Router - Kamailio (OpenSER) and SIP Express Router (SER) - Users Mailing List" <sr-users at lists.sip-router.org<mailto:sr-users at lists.sip-router.org>>
Date: Thu, 22 Sep 2011 19:11:30 +0200
To: kamailio users <sr-users at lists.sip-router.org<mailto:sr-users at lists.sip-router.org>>
Subject: [SR-Users] perl module compilation on centos


while building the v3.1.5 RPMs, the perl module failed to compile on centos 5 and 6, with following error:

error: `PL_unitcheckav' undeclared (first use in this function )

so its packaging was disabled. It works fine on opensuse and fedora. Someone on twitter tried with the package perl-ExtUtils-Embed (like in fedora) and worked. However, OpenSUSE Build System fails to find that package.

Is anyone here with latest centos 5 or 6 that can try compilation of perl module in v3.1.5 and let me know the result? Few months ago, it didn't fail for v3.1.4.


Daniel-Constantin Mierla -- http://www.asipto.com
Kamailio Advanced Training, Oct 10-13, Berlin: http://asipto.com/u/kathttp://linkedin.com/in/miconda -- http://twitter.com/miconda
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-users/attachments/20110922/ce6a963a/attachment.htm>

More information about the sr-users mailing list