[Kamailio-Users] New install woes - 1.5.3 w/ mysql

Graham Wooden graham at g-rock.net
Fri Jan 1 06:03:06 CET 2010

Hi all,

Apparently I am missing something fundamentally here; trying to get mysql
functions working with the kamdbctl command, but it seems that while it
locates the kamdbctl.mysql file, it can¹t locate/use the the locate_tool()
function from the Œkamctl.base¹ (which is called at the top of
kamdbctl.mysql). I have been going back through trunk/INSTALL file and not
seeing anything that is standing out. Neither when I ³strace² the Œkamdbctl
create¹ command.  But seems that my environment is missing something.  I
don¹t recall such issues with my production 1.4.2 machine.

It¹s a fresh install CentOS 5.4 with most items (e.g. mysql server/client)
installed via the standard yum repo¹s.  I tried 1.5.3 from both building it
from source as as well as the linux/i386 binary set.  Still the same
results.  Thoughts?

[root at misfits kamailio]# kamctl start
database engine 'MYSQL' loaded
Control engine 'FIFO' loaded

INFO: Starting Kamailio :
INFO: started (pid: 9006)

[root at misfits kamailio]# kamdbctl create
/usr/local/lib/kamailio/kamctl/kamdbctl.mysql: line 25: locate_tool: command
not found
error: 'mysql' tool not found: set MYSQL variable to correct tool path

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-users/attachments/20091231/3a67e3b0/attachment.htm>

More information about the sr-users mailing list