[Kamailio-Users] Problem starting Kamailio

Daniel-Constantin Mierla miconda at gmail.com
Mon Mar 16 14:46:08 CET 2009


On 03/16/2009 03:01 PM, Henning Westerholt wrote:
> On Monday 16 March 2009, Sara EL KABIRI wrote:
>> Thanks.
>> I have already logged on to the mysql server and granted all the privileges
>> to the user that was being rejected at kamailio's database
>> authentication... And i still get the same error.
> Hi Sara,
> have you tried to login with the 'mysql' console client using the same 
> credentials as in the configuration? MySQL is sometimes a bit picky with the 
> hostnames..
>> What i don't understand is that in Kamailio's config file, whether i set
>> the db_url parameter to the "root" user or to the "openser" one:
>> *modparam("uri_db", "db_url", "mysql://root:<password>@localhost/openser")*
>> or
>> *modparam("uri_db", "db_url", "mysql://openser:<password>
>> @localhost/openser")*
>> i get indifferently "*Access denied for user 'openser'@'localhost' (using
>> password: YES)*".
> Perhaps you've some modules without a modparam statement that configures a 
> db_url in your cfg. They will then use the default credentials which 
> are 'openser' and a default password. I noticed in the logs that the usrloc 
> module fails for example, do you've a db_url for this module too?
from the previous logs, seems that the module with problems is usrloc - 
check if db_url for that module is set properly.


Daniel-Constantin Mierla

More information about the sr-users mailing list