[Serusers] rtpproxy syntax error

- zaki - zaki at zaki.jp
Fri Feb 20 06:07:28 CET 2004


I've tried to use portaone rtpproxy with nathelper, but it looks
there is interoperability problem.

# export CVSROOT=:pserver:anonymous at cvs.berlios.de:/cvsroot/ser
# cvs co -r rel_0_8_12 sip_router
# (cd sip_router; make install)
# cvs co rtpproxy
# (cd rtpproxy; ./configure; make install)
# cp sip_router/etc/nathelper.cfg /usr/local/etc/ser/ser.cfg

After editing ser.cfg to fit my site and starting ser and rtpproxy,
when I tried to make a call from an endpoint A behind NAT to endpoint
B behind NAT, signaling was OK(endpoint was ringing), but no media.

In my /var/log/messages, following message appeared.
"ERROR: send_rtpp_command: can't connect to RTP Proxy"
So I traced rtpproxy process by "strace -p <rtpproxy's PID> -f -F",
then I saw "rtpproxy: command syntax error:" message.
I think there are no message format compatibility between sip_router
(branch rel_0_8_12) and rtpproxy(latest).

Should I use another version to work them together?



More information about the sr-users mailing list