[Serusers] forwarding to PSTN

Srbislav Cvetkovic srbislav at city-net.com
Tue Feb 3 19:15:08 CET 2004

ok maybe i need to explain into more details what I am trying to do. I 
have 5 POTS lines in my office. If any of them ring the other 4 lines 
or phones can pick up the call by dialing *74. It is a feature we have 
through our phone provider. Now I am trying to set up ser system and I 
have couple of grandstream phones. I can dial out using my VEGA 
gateway. But I would like to use the call pick up feature I have 
already. My gateway is configured to take anything that comes from my 
sip proxy ( ser in this case ), so I need to configure ser to send *74 
onto my gateway. I tried using the same approach as for regular phone 
numbers but it is not working. I am not surprised :) I tried putting 
\*74 but that is not working either. I am getting the same error, and 
there is nothing in the log file.

I hope this makes it a little bit more clear.


On Tuesday, February 3, 2004, at 12:46  PM, Klaus Darilion wrote:

> Srbislav Cvetkovic wrote:
>> Hello everyone,
>> My phone system has a call pick-up functionality tht I would like to 
>> implement in my voip system. We have couple of phones, and once the 
>> phone rings anyone in the office can pick up that call by pressing 
>> *74. I am trying to do the same thing with ser. Can anyone help me 
>> with the uri check please? This is what I have:
>> route[1] {
>>                 # Route to PSTN Gateways(s)
>>         if (uri=~"^sip:9[0-9]*@sip_gateway.com") {        ##  This 
>> assumes that the caller is
>>             log("Forwarding to PSTN\n");                ##  
>> registered in our realm
>>             strip(1);
>>             t_relay_to_udp( "sip_gateway.com", "5060" );
>>             break;
>>         };
>>         if (uri=~"^sip:*74@ sip_gateway.com") {        ##  This 
>> assumes
> I did't understand who you will do the call pickup, but this 
> comparison uses regular expressions, so you have to escape the * with 
> a \
> ^sip:\*74 at sip_gateway.com
> klaus
>> that the caller is
>>             log("Picking up a Call on PSTN\n");                ##  
>> registered in our realm
>>             t_relay_to_udp( "sip_gateway.com", "5060" );
>>             break;
>>         };
>> }
>> I am getting 404 error on my grandstream phone. I think there is a 
>> problem with the "*" symbol. I guess i am using it wrong. How do I 
>> send * followed by 74 to my gateway?
>> thanks,
>>  Srbo Cvetkovic                  | CityNet, Inc.        
>> srbo at city-net.com            | Pittsburgh, PA    voice: 412.481.5406  
>>        | fax: 412.431.1315
>> _______________________________________________
>> Serusers mailing list
>> serusers at lists.iptel.org
>> http://lists.iptel.org/mailman/listinfo/serusers

  Srbo Cvetkovic                  | CityNet, Inc.		
  srbo at city-net.com            | Pittsburgh, PA	
  voice: 412.481.5406         | fax: 412.431.1315

More information about the sr-users mailing list