[Serusers] restart problems with 0.8.10 and >6000 locations

Jiri Kuthan jiri at iptel.org
Mon Jul 7 10:39:39 CEST 2003


there is a shortcoming in SER -- it tries to preload all contacts in
private memory during boot-up  before placing them in shared memory
in a single batch.

A workaround for now is increase the private memory limit. Edit file 
config.h and set PKG_MEM_POOL_SIZE to higher value (it is in bytes) and 
recompile ser.

We will introduce incremental loading later.


At 08:36 AM 7/7/2003, Volker Voigt wrote:
>I'm using ser 0.8.10 with mysql on RedHat 8.1. For some loadtests I
>generated 10000 REGISTERs with sipsak. Worked fine. I stopped ser and tried
>to restart it. During that I found out that ser won't start if more than
>~6000 entries are in the location table of mysql. The start script says
>"OK", but a "ps aux" afterwards shows that no ser process is running. A look
>into /var/log/messages shows nothing (debug level set to 9). After reducing
>the number of entries with the mysql command client to <6000 ser will start
>up and copy the entries to its memory, as 'serctl monitor' shows. Am I
>missing something?
>Best regards,
> Volker
>Serusers mailing list
>serusers at lists.iptel.org

Jiri Kuthan            http://iptel.org/~jiri/ 

More information about the sr-users mailing list