[sr-dev] [SR-Users] kamailio 3.1.3 fail to start as a service when load the ldap.so module

Daniel-Constantin Mierla miconda at gmail.com
Tue Jun 21 14:33:32 CEST 2011

On 6/21/11 12:33 PM, laura testi wrote:
> The LDAP server is running on another machine in the same LAN without 
> any firewall.
> As by your suggestion, I change the user and group from kamailio to 
> root in the /etc/default/kamilio file. Now it works.
> Why I can not run the kamailio as the user kamailio as the default 
> installation set? (I install the kamilio from rpm and the user and 
> group of kamailio are already created by the installation)
> wuthout ldap.so, I can run the kamilio from the user kamailio normally 
> when I run "service kamailio start" from root.
Is the ldap module configuration file readable by user kamailio?


> On Tue, Jun 21, 2011 at 12:07 PM, Daniel-Constantin Mierla 
> <miconda at gmail.com <mailto:miconda at gmail.com>> wrote:
>     Hello,
>     interesting, is the ldap server running on same server? Is the
>     connection via local network?
>     When starting as service, kamailio is probably run under user
>     kamailio. Any firewall in place or system restrictions for user
>     'kamailio'?
>     You can change the user/group for kamailio service in
>     /etc/default/kamailio
>     Cheers,
>     Daniel

Daniel-Constantin Mierla -- http://www.asipto.com
http://linkedin.com/in/miconda -- http://twitter.com/miconda

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-dev/attachments/20110621/60c034c2/attachment.htm>

More information about the sr-dev mailing list