[sr-dev] Kamailio Installation

Suresh Bhandari bring2me at gmail.com
Sun Feb 27 09:07:19 CET 2011

Hello Community,

I am new to Kamailio, and this list as well.

I am trying to install Kamailio 3.1.2, but I am getting too many errors. I
have fixed some but still not getting the way.

I am using Red Hat Enterprise Linux (RHEL) 5, and /usr/local directory.

When I ran the following command:

make group_include="standard standard-dep mysql"
include_modules="carrierroute peering" install

it prompted not found error for the file docbookx.dtd, I found it
(modules/auth/auth.xml, and modules_s/acc_syslog/acc_syslog.xml) and fixed
it as it was errorenous URL location.

For reference earlier it was
http://www.oasis-open.org/docbookid/id/g/4.5/docbookx.dtd, which I changed
to http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd.

Now when I run the previous command again, I am getting the follwing errors:
"X20AC" is not a function name*

If I ignore this, and continue, I am not able to find the "sip-router"
service in /etc/init.d.

The entire errors is attached here.

Please help me solve the issue.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sip-router.org/pipermail/sr-dev/attachments/20110227/e96d77d8/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: kamailio_error.log
Type: text/x-log
Size: 50 bytes
Desc: not available
URL: <http://lists.sip-router.org/pipermail/sr-dev/attachments/20110227/e96d77d8/attachment.bin>

More information about the sr-dev mailing list