[sr-dev] sr_3.0 problems with header adding/removing

Andrei Pelinescu-Onciul andrei at iptel.org
Thu Nov 5 21:37:48 CET 2009

On Nov 05, 2009 at 19:49, Klaus Darilion <klaus.mailinglists at pernau.at> wrote:
> Hi!
> I have followings problems with sr_3.0 branch (4.11.2009)

Could you send me the last part of the version number reported by ser -V,
version: ser 2.99.99-pre3 (i386/linux) 6fcba9
                                       ^^^^^^^ this one

or the output of git rev-parse HEAD .

(given your previous email I'm not sure that you really are on the
sr_3.0 branch and it might be a bug that was already fixed)

> remove_hf("") does not work. Header fields (I tried various ones) are 
> not removed.
> record_route(): I call record_route() but the RR header is not added. I 
> tried both, K's and ser's rr module - both do not work.

I've tried both ser & k version with latest sr_3.0 and it works for me
(I even tried remove_hf in the on_branch route).

Do you have any other special non-default options set?


More information about the sr-dev mailing list