[SR-Dev] git:master: * Module: presence
miconda at gmail.com
Tue Apr 21 19:04:21 CEST 2009
On 04/21/2009 06:59 PM, Juha Heinanen wrote:
> Daniel-Constantin Mierla writes:
> > wouldn't be better to have this function named: watcher_auth_status()
> > (or ps_auth_status() - ps from presence server, or other prefix like
> > pres, presence)? It will be more suggestive about provided
> > functionality.
> presence module has in its api a function called 'get_auth_status'. i
> just more or less reused the name so if someone reads presence module
> readme, he/she can easily associate those two.
internally it is used via some structure, like pres.get_auth_status().
In config we do not have that. Lot of functions have different names in
C and config.
As it is now, function name suggest more sip auth status with no
relation to presence or watcher. Just my opinion. We had discussions in
the past how to make names for suggestive in relation with provided
functionality and the module that exports them.
More information about the sr-dev