[Devel] [ openser-Bugs-1602338 ] openserunix tool not working

SourceForge.net noreply at sourceforge.net
Mon Nov 27 19:16:39 CET 2006

Bugs item #1602338, was opened at 2006-11-24 17:27
Message generated for change (Comment added) made by dan_pascu
You can respond by visiting: 

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: tools
Group: ver 1.1.x
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Dan (dan_pascu)
Assigned to: Nobody/Anonymous (nobody)
Summary: openserunix tool not working

Initial Comment:
The openserunix tool cannot work as it is now.

The usage pattern is like this:

echo "command" | openserunix /tmp/openser.sock

However the command should include the name of the receiving socket, but that is unknown as it is a random string generated by openserunix later after receiving the command. This leads to a chicken and egg problem.

As a result configuring openserctl to use the UNIX socket interface will result in openserctl not working.


>Comment By: Dan (dan_pascu)
Date: 2006-11-27 20:16

Logged In: YES 
Originator: YES

It seems the UNIX socket interface doesn't require the path to the reply
socket in the command and ignores it. As a result the previous comment of
openserunix not being able to work with its current architecture is

However openserunix still doesn't work (probably it has something to do
with the reply socket creation umask).

If I run openserunix as root:

echo -en ":version:\n\n" | sudo openserunix /var/run/openser/socket

it locks as it doesn't receive a reply from openser, while openser outputs
this error to syslog:

Nov 27 19:11:50 node06 /usr/sbin/openser[17554]: ERROR: tsend_dgram:
failed to send: (13) Permission denied
Nov 27 19:11:50 node06 /usr/sbin/openser[17554]: unix_server_loop: Command
'version' failed with return value -1

If I try to run openserunix as the same user as openser:

echo -en ":version:\n\n" | sudo -u openser openserunix

it gives this error message:

Error in recvfrom: Invalid argument

while openser doesn't give any error in syslog.


You can respond by visiting: 

More information about the Devel mailing list