HI bogdan,
I am so sorry, I thought only develepment versions are hosted in cvs.
Thanks for correcting.

Bogdan-Andrei Iancu <bogdan@voice-system.ro> wrote:
The cvs hosts all openser versions, stable and development. 1.0.1 is the
latest stable version and can be fetched as tarballs or from CVS.


Padmaja RV wrote:

> Hi Jayesh,
> Thank you so much for the reply. I have downloaded
> the version openser-1.0.1 from cvs. I thought that is a stable release
> and no changes are going to be made to it. Do i have to again revert
> to the tar.gx version? Also please look at what happened when i
> previously installed the .tar.gz version of openser before doing the cvs
> 1. downloaded openser-1.0.1-linux_i386.tar.gz version as root.
> 2. It is now under / (the root directory). after that i did unzip and
> untar on that.
> 3. the file and modules are loaded into the subdirectories of the /usr
> directory.I could not anywhere find a standalone directory called
> openser-1.0.1 with the directory sip-server in it. also there is no
> makefile here.... (All these i see when i download it thru CVS in the
> /usr/local/src directory.)
> 4. I tried to see through the list for the module mysql.so but i could
> not find it....and so for uri_db module also. these modules are
> present when i install openser thru cvs
> 5. i did not do any make on it. I thought it is precompiled version
> and will automatically get installed when i do the untar and unzip.
> please correct me if the tar version also has to go thru make
> 6. i ran openser through /usr/local/sbin/openser start. and it ran
> successfully... it showd the tcp and udp ports on which it is
> running..i could register my sip UA without authentication.
> 7. then i wanted to set it up for mysql support. i edited the config
> file and uncommented the necessary modules and tried to create the
> openser databse in mysql. here it failed stating ha1 calculation
> failed.. also it states there is no mysql.so module which is true.
> Please let me know if I have made any mistakes in the installation
> process.... I am new to openser.. now if i want to revert to .tar.gz
> version, will all the openser modules and config files from the cvs be
> replaced by the tar.gz version? or will there be duplicate entries left?
> Thanks again
> Regards,
> Padmaja
> ----- Original Message -----
> *From:* Jayesh Nambiar
> *To:* users@openser.org
> *Cc:* padmaja.rv@vodcalabs.com
> *Sent:* Wednesday, May 31, 2006 12:08 PM
> *Subject:* [Users] Re: how to run openser through monit daemon?
> Hi padmaja,
> Running openser from cvs would not solve your problem. Openser
> from cvs is the development version which will be released
> after final testing is done.
> To be safe, its better if you use .tar.gz file to install. For
> enabling mysql, go to the openser directory and you'll find a
> makefile. In the makefile there is a line exclude_modules?=
> somewhere around line no.49. From there just remove mysql and
> recompile it again.
> You can start openser using openserctl start from the command
> line.
> To check for some errors you can set debug=9 in the
> openser.cfg file.
> Normally the logs are stored into /var/log/messages. You can
> check for errors in this file.
> Hi!
> there is something I need to mention here with respect to
> openser not
> working.....
> Initially I had openser installed from .tar.gz and i could run
> it from
> /usr/local/sbin/openser. It worked fine that way without any
> authentication.
> I could see local registration of my sip UAs with the openser
> being
> successful. then i set up mysql. It too started successfulyy
> thru webmin.
> next I tried to create the openser database in mysql from
> /usr/sbin/openser_mysql.sh create. It prompted me for the root
> password of
> mysql, the domain name and then failed stating that the Ha1
> calculation
> failed. also when i tried to modify the openser.cfg file to
> support mysql
> database i found that there is no mysql.so module in the
> /usr/local/lib/openser/modules/ path.
> Because of the above problems, I tried installing openser from
> CVS and here
> all the modules and configuration files are present in the
> respective
> locations as mentioned in the web link for installing openser.
> I could even
> create the openser database structures in mysql. i tried
> uncommenting the
> needed modules for database suppport. now when i try to run
> openser thru
> monit, there is absolutely no response and openser does not
> look like
> running............
> I am a newbie at openser......please help me which way i
> should run
> openser.....
> thanks and regards,
> Padmaja
> ------------------------------------------------------------------------
> Yahoo! India Answers: Share what you know. Learn something new
> Click here
> Send free SMS to your Friends on Mobile from your Yahoo! Messenger
> Download now
>Users mailing list

Yahoo! India Answers: Share what you know. Learn something new Click here
Send free SMS to your Friends on Mobile from your Yahoo! Messenger Download now